Содержание

GDV Diagram > Введение

GDV Diagram

Введение

Назначение программы

Системные требования

Рекомендуемая конфигурация

Уровень подготовки пользователя

Работа с программой

Общее описание программы

Добавление записи о новом испытуемом

Загрузка ГРВ-грамм

Съемка ГРВ-грамм

Калибровка

Групповая калибровка

Фильтрация шума

Режимы псевдоокрашивания

Корректировка центра и эллипса для ГРВ-граммы пальца

Меню ГРВ-граммы

Построение и просмотр диаграммы

Просмотр графиков интегральных параметров

Таблица данных

Печать ГРВ-грамм

Печать графиков и таблиц

Сохранение печатаемых документов

GDV Diagram > Введение


Назначение программы

Программа GDV Diagram предназначена для анализа функционального состояния организма испытуемых путем расчета комплексных ГРВ параметров по органам и системам организма и их сравнения с эталонными параметрами практически здорового человека. Полученная информация отображается в графической форме в виде круговых диаграмм. Дополнительно программа позволяет рассчитать уровень активации испытуемого. Для осуществления анализа необходимо загрузить в программу статические ГРВ-граммы 10 пальцев рук человека, отснятых без фильтра и со специальным фильтром.

Демонстрационная версия позволяет работать только со встроенными в программу данными, а функции создания, загрузки и сохранения файлов испытуемых заблокированы, также невозможно загрузить ГРВ-граммы с диска или запустить программу GDV Capture 2 для их съемки.

Программа может одновременно обрабатывать данные для нескольких испытуемых причем, для каждого из них возможно наличие нескольких ГРВ-съемок (например, произведенные в разные дни). ГРВ-съемка это один или два набора файлов ГРВ-грамм пальцев испытуемого, соответствующих регистрации без фильтра и с фильтром. Для того, чтобы рассчитать уровень активации испытуемого необходимо наличие обоих наборов файлов. При наличии только ГРВ-грамм без фильтра будут рассчитана только диаграмма распределения ГРВ-параметров по органам и системам организма.

Список съемок и личные данные испытуемого (имя, пол, возраст и т.п.) сохраняются в файле на диске. Поэтому, для обработки данных испытуемого необходимо либо создать новый файл, либо загрузить ранее созданный, а затем добавить в него новую съемку. При закрытии программы или при удалении испытуемых из списка будет выдан запрос на сохранение всех сделанных изменений в данном сеансе работы.

Таким образом, типичная последовательность работы с программой выглядит следующим образом:

  1. Создание нового файла испытуемого или загрузка уже имеющегося;

  2. Добавление новой съемки;

  3. Загрузка ГРВ-грамм исследуемого испытуемого с фильтром и без фильтра;

  4. Калибровка (если эта процедура не была выполнена ранее);

  5. Проверка установок фильтрации шума, режима псевдоокрашивания, и если это необходимо, осуществление их корректировки;

  6. Корректировка вписанного эллипса;

  7. Построение диаграммы распределения ГРВ-параметров по органам и системам организма;

  8. Построение графиков интегральных параметров;

  9. Построение таблицы числовых данных;

  10. Печать и сохранение результатов.

GDV Diagram > Введение > Назначение программы


Системные требования

Программа может работать в следующих операционных системах (ОС) семейства Windows фирмы Microsoft :

  • Windows 2000

  • Windows XP

  • Windows Vista

  • Windows 7

Рекомендуемая конфигурация компьютера

Рекомендуемая конфигурация компьютера:

  • 32-разрядный (x86) или 64-разрядный (x64) процессор с тактовой частотой 1 гигагерц (ГГц) или выше;

  • 1 гигабайт (ГБ) (для 32-разрядной системы) или 2 ГБ (для 64-разрядной системы) оперативной памяти (ОЗУ);

  • 16 гигабайт (ГБ) (для 32-разрядной системы) или 20 ГБ (для 64-разрядной системы) пространства на жестком диске;

  • графическое устройство DirectX 9 или выше.

Уровень подготовки пользователя

Уровень подготовки пользователя:

  • навыки работы с ПК в операционной среде Windows


Работа с программой

Общее описание программы

Добавление записи о новом испытуемом

Загрузка ГРВ-грамм

Съемка ГРВ-грамм

Калибровка

Групповая калибровка

Фильтрация шума

Режимы псевдоокрашивания

Корректировка центра и эллипса для ГРВ-граммы пальца

Меню ГРВ-граммы

Построение и просмотр диаграммы

Просмотр графиков интегральных параметров

Таблица данных

Печать ГРВ-грамм

Печать графиков и таблиц

Сохранение печатаемых документов

GDV Diagram > Работа с программой


Общее описание программы

Интерфейс программы GDV Diagram организован в виде диалога, содержащего последовательно переключаемые страницы. Часть страниц доступна только после загрузки или обработки данных. Интерфейс программы построен таким образом, чтобы пользователь мог последовательно выполнить все этапы стандартной процедуры анализа.

При запуске программы отображается стартовая страница:

При выборе кнопки Описание программы появится инструкция описания работы с программой.

Пункт меню О программе отобразит данные об установленной версии программы, время и дату её сборки, номере подключенного ключа, и, кроме того, здесь имеется возможность поменять язык пользовательского интерфейса на любой из поддерживаемых в программе без переустановки программы. Для этого необходимо установить галочку на нужном языке и перезапустить программу. Язык интерфейса изменится для всех программ пакета.

Кнопка Начать работу осуществит переход на страницу Список испытуемых.

В верхней правой части страницы Список испытуемых располагается меню программы.

При нажатии на кнопку Страница появляется меню со списком всех страниц, в котором в произвольном порядке можно осуществлять переход на другие страницы программы. Текущая страница выделяется галочкой, выбрать другую можно с помощью левой кнопки мыши, но при этом следует учитывать, что часть страниц будет доступна только после загрузки или обработки ГРВ-грамм. Переключение между страницами в процессе работы можно осуществлять последовательно - с использованием кнопок Предыдущая и Следующая, расположенных в меню Страница, или Назад и Дальше в нижней правой части страницы Список испытуемых.

В том случае, если ГРВ-граммы уже загружены, меню, при нажатии на кнопку Страница появляется возможность переходить на нужную Вам страницу.

При нажатии на кнопку Действие появляется меню со списком допустимых действий на данной странице, который включает как операции общие для всех страниц программы ("Загрузить данные испытуемого", "Новый испытуемый" и т.д.), так и специфические операции для текущего рабочего окна. Например, "Групповая калибровка". Данная опция позволяет сделать групповую калибровку, раннее откалиброванных съемок по новому алгоритму калибровки.

При выборе ГРВ-мм появляется возможность, при нажатии кнопки Дальше перехода на следующую страницу.

При нажатии на кнопку Действие снова появляется меню со списком допустимых действий на данной странице.

Список допустимых действий на данной странице включает, как операции общие для всех страниц программы ("Новый испытуемый", "Убрать из списка", "Загрузить данные испытуемого", и т.д.), так и специфические операции для текущего рабочего окна, например, "Редактировать данные съемки". Данная опция позволяет изменить и добавить комментарии, название съемки и др.

Кнопка Дальше осуществит переход на страницу ГРВ-граммы. При нажатии на кнопку Действие снова появляется меню со списком допустимых действий на данной странице, который включает как операции общие для всех страниц программы ("Калибровка", "Новый испытуемый", "Закрыть программу" и т.д.), а так же и специфические операции для текущего рабочего окна, например, "Информация о последней калибровке". Данная опция позволяет узнать все параметры последней калибровки для данной съемки.

Кнопка Программы позволяет запустить любую из программ пакета GDV Software, установленных на данном компьютере. После запуска выбранной программы, в нее автоматически загружаются те же файлы испытуемых, которые уже открыты в текущей программе. При дальнейшей работе будет происходит автоматическая синхронизация измененных данных между всеми программами, в которые загружен изменяемый файл испытуемого.

GDV Diagram > Работа с программой > Общее описание программы


Добавление записи о новом испытуемом

На странице Список испытуемых расположены два списка, верхний из которых отвечает за информацию об испытуемых, а нижний за информацию о съемках, закрепленных за каждым из загруженных в верхнем списке испытуемых.

Для работы с программой необходимо добавить информацию о новом испытуемом в верхний список. Это осуществляется с помощью кнопки Новый испытуемый

Личные данные испытуемого, а также список файлов ГРВ-грамм сохраняются в файле с расширением .sbj. Файл создается на диске и обновляется его содержимое в момент завершения работы с программой или после нажатия кнопки Сохранить изменения, расположенной в нижнем правом углу. Внутри файла содержатся ссылки на файлы ГРВ-грамм. Для переноса информации на другой компьютер вы должны скопировать необходимые .sbj файлы вместе с соответствующими файлами ГРВ-грамм, причем с сохранением их взаимного расположения в структуре каталогов.

Для удобства хранения и переноса информации на другие компьютеры, рекомендуется поддерживать определенную структуру папок данных испытуемых на диске. В частности очень удобен следующий вариант, изображенный на схеме. В этом случае, для переноса информации, например об Иванове, потребуется просто скопировать папку Иванов со всеми содержимым (Съемка(5.06.2005),Съемка(10.11.2005)) и файл Иванов.sbj. Если не требуется переносить ГРВ-граммы, то можно ограничится копированием .sbj файла. В этом случае программа позволит просматривать ранее рассчитанные данные, но повторная обработка будет недоступна.

При нажатии на кнопку Новый испытуемый появится карточка испытуемого.

Имя файла - в этой строке указан путь к папке, в которой будет сохранен .sbj файл и его имя. Имя файла формируется автоматически из строки Имя, в которой по умолчанию всегда стоит Испытуемый 1. С помощью кнопки Обзор, можно установить необходимый путь для сохранения .sbj файла.

В верхней части карточки вводятся личные данные испытуемого: имя испытуемого - в строке Имя (например, Петров Иван Васильевич), указывается дата рождения, выбирается пол и, если это необходимо, пишется комментарий к испытуемому. Кнопка [image] позволяет вносить или редактировать дату рождения испытуемого при помощи календаря.

В нижней части карточки расположены элементы управления, которые позволяют добавить ГРВ-съемку для данного испытуемого.

Название съемки - по-умолчанию будет присвоено название "Съемка 1". При необходимости, можно ввести название соответствующее специфике проводимого исследования (например, до воздействия и после воздействия). Строка Дата заполняется автоматически после загрузки или съемки ГРВ-грамм. В поле Комментарий при необходимости можно ввести дополнительную информацию о съемке.

Прямо из карточки Вы можете отснять новые ГРВ-граммы, запустив программу GDV Capture 2 и нажав кнопку Съемка ГРВ-грамм. Или загрузить имеющиеся ГРВ-граммы с диска, нажав Загрузка ГРВ-грамм. Данные операции выполняются последовательно для ГРВ-грамм без фильтра и с фильтром.

По завершению ввода данных нажмите кнопку Готово, и на странице Список испытуемых появятся записи об испытуемом и ГРВ-съемке.

Перед именем испытуемого и названием съемок имеются галочки для включения/выключения обработки отдельного испытуемого или отдельной съемки. Т.е. можно обрабатывать/просматривать не все загруженные, а только выборочный набор съемок и не всех загруженных испытуемых, а только выборочных. Включить/выключить галочку можно одиночным нажатием левой кнопки мыши.

Для работы с верхним списком испытуемых в программе предусмотрены следующие кнопки, расположенные под списком.

Кнопка Загрузить позволяет загрузить информацию об испытуемом из сохраненного ранее .sbj файла через стандартное окно открытия файлов Windows.

Кнопка Загрузить по списку открывает окно формирования списка .sbj файлов для загрузки. Эту функцию удобно использовать, если Вам необходимо открыть большое количество .sbj файлов из одной или нескольких папок, при этом допускается задание шаблона имени файла или папки.

В окне отображается список файлов с расширением .sbj, которые требуется открыть. Отредактировать список можно с помощью кнопок:

  • позволяет добавить в список все файлы с расширением .sbj из выбранной папки на диске;

  • удаляет выделенные файлы с расширением .sbj из списка;

  • удаляет все файлы с расширением .sbj из списка

С помощью Шаблона папки и Шаблона имени файла можно загружать в список не все файлы, а только те, которые соответствуют определенному условию. В этих полях ввода можно ввести любую часть имени папки или файла. При этом допускается использование двух специальных символов "*" и "?". "*" - означает любое кол-во (включая 0) любых символов. "?" - означает ровно один любой символ. Например, у Вас имеется набор файлов 10 пальцев рук человека, и Вам требуется открыть файлы пальцев правой руки, отснятых с фильтром, для этого в поле Шаблона папки прописывается *Filter*, а в Шаблон имени файла записывается ?R* (естественно, для этого необходимо чтобы файлы и папки на диске были поименованы соответствующим образом). Тогда при сканировании выбранной папки в список загрузятся только нужные файлы.

По окончании выбора всех параметров нажмите кнопку ОК.

С помощью кнопки Редактировать можно внести изменения в личные данные выделенного в списке испытуемого.

Кнопка Убрать из списка позволяет удалить из программы выделенную запись об испытуемом. Это действие не приводит к удалению файла данных испытуемого на диске, а только позволяет освободить память программы.

С помощью кнопки Очистить список можно удалить все загруженные данные из памяти программы.

Для работы с нижним списком предусмотрены следующие кнопки:

  • Добавить съемку - позволяет добавить новую съемку для выделенного в верхнем списке испытуемого;

  • Редактировать - кнопка дает возможность внести изменения и добавить комментарии для выделенной в нижнем списке съемки;

  • Кнопка Удалить съемку удаляет выделенную съемку из нижнего списка;

  • Сохранить внесенные изменения можно с помощью кнопки Сохранить изменения...

Переход к следующей странице ГРВ-граммы осуществляется с помощью кнопки Дальше.

GDV Diagram > Работа с программой > Добавление записи о новом испытуемом


Загрузка ГРВ-грамм

Загрузка ГРВ-грамм выполняется на странице ГРВ-грамм, а также в карточке испытуемого, с помощью кнопки Загрузить ГРВ-граммы.... Файлы ГРВ-грамм обязательно должны содержать в своем имени индексы пальцев 1R - 5R, 1L - 5L.

Для загрузки ГРВ-грамм необходимо в появившемся окне, после нажатия кнопки Загрузить ГРВ-граммы..., указать путь к папке, в которой хранится набор ГРВ-грамм, затем нажать последовательно на кнопки Выделить все и Открыть.

В окно ГРВ-грамм загружаются изображения ГРВ-грамм испытуемого.

В программу загружаются ГРВ-граммы, отснятые без фильтра.

С помощью кнопки Калибровка можно провести калибровку загруженных ГРВ-грамм.

Кнопка Печать ГРВ-грамм поможет распечатать изображение загруженных ГРВ-грамм с наложением секторного разбиения по Короткову.

Кнопка Загрузить ГРВ-граммы позволяет заново загрузить ГРВ-граммы.

GDV Diagram > Работа с программой > Загрузка ГРВ-грамм


Съемка ГРВ-грамм

На странице ГРВ-граммы распологается кнопка Съемка ГРВ-грамм... (указана курсором на рисунке), которая позволяет проводить съемку ГРВ-грамм из любой программы пакета GDV Software.

Процесс съемки ГРВ-грамм осуществляется в программе GDV Capture 2. При сохранении отснятых ГРВ-грамм в этой программе, автоматически будет создаваться следующая структура папок на диске:

...

<Испытуемый 1>.sbj

<Испытуемый 1> (GDV Images)

<Название съемки 1>

ГРВ-граммы без фильтра

1R.bmp

2R.bmp

3R.bmp

…

ГРВ-граммы с фильтром

1R.bmp

2R.bmp

3R.bmp

…

Строки, содержащиеся в < >, заменятся данными введенными пользователем при создании учетной записи испытуемого и ГРВ-съемки.

До тех пор пока программа GDV Capture 2 не будет закрыта, работа вызывающей программы блокируется. После сохранения зарегистрированных ГРВ-грамм и закрытия программы GDV Capture 2, изображения автоматически загрузятся в окно ГРВ-граммы. Последовательность съемки ГРВ-грамм подробно описана в инструкции к программе GDV Capture 2.

GDV Diagram > Работа с программой > Съемка ГРВ-грамм


Калибровка

Калибровка ГРВ-прибора – это процесс регистрации нескольких ГРВ-грамм тест-объекта и последующей их обработки с целью контроля технического состояния прибора, а также для получения площади свечения тест-объекта, которая необходима для расчетов в различных программах пакета GDV Software.

Калибровку необходимо выполнять в следующих случаях:

  • перед началом эксплуатации нового прибора;

  • при подключении прибора к компьютеру, на котором ранее калибровка не проводилась;

  • после переключения с AC/DC преобразователя 110-240В/12В на питание от аккумулятора (и в обратном направлении);

  • при переносе прибора в другое помещение или из помещения на открытый воздух и обратно;

  • при изменении климатических условий в помещении, где проводится съемка: при изменении температуры более чем на 5ºC или влажности более чем на 10 %;

  • при появлении внешнего источника электромагнитного излучения вблизи прибора и, наоборот, при переносе прибора в зону с обычным или низким уровнем электромагнитных помех;

  • один раз в 6 месяцев во всех остальных случаях.

Процесс калибровки начинается со съемки или загрузки ГРВ-грамм тест-объекта. Для обработки необходимо не менее 10 ГРВ-грамм тест-объекта (первые пять съемок тест-объекта не сохраняем, а переснимаем). Перед началом обработки все изображения требуется сохранить. Важно убедиться, чтобы ГРВ-граммы тест-объекта не содержали таких дефектов как, засветка, "запыления" внутреннего овала из-за неровного положения тест-объекта и т.д. Данные дефекты могут исказить калибровочную информацию, что, в свою очередь, не позволит в дальнейшем получить достоверную информацию в программах обработки ГРВ-грамм.

Для проведения калибровки необходимо нажать кнопку Калибровка... в нижней левой части окна ГРВ-граммы.

Будет запущена программа GDV Capture 2 в режиме калибровки.

Более подробное описание процедуры калибровки, загрузки или съемки ГРВ-грамм смотрите в инструкции к программе GDV Capture 2 в разделе Работа с программой.

GDV Diagram > Работа с программой > Калибровка


Групповая калибровка

Начиная с версии 2.7.0 программы GDV Capture 2 был значительно усовершенствован алгоритм получения калибровочных данных, при этом формат сохранения информации и набор расчетных параметров не изменился. Поэтому, при обработке в новых версиях ГРВ-программ (начиная с 2010 года) ГРВ-грамм, которые были ранее зарегистрированы программой GDV Capture 2 версии более ранней чем 2.7.0, будут получены неверные результаты. Во избежание этого, необходимо заново рассчитать калибровочные данные в последней версии программы GDV Capture 2 и записать эти данные в файлы ГРВ-грамм. Сделать это можно двумя способами:

  1. Для одной выбранной съемки одного испытуемого:
    1. Загрузить sbj-файл испытуемого в любую из программ пакета GDV Software, работающую с расширением *.sbj (GDV Diagram, GDV Energy Field и т.д.).
    2. Перейти на страницу ГРВ-грамм и выбрать нужную съемку.
    3. Нажать кнопку Калибровка… в левом нижнем углу окна программы или выбрать пункт Калибровка… из меню Действие.
    4. Запустится GDV Capture 2. Для дальнейшей работы нажимаем на кнопку ОК предупредительного всплывающего окна.
    5. Нажмите кнопку Загрузить ГРВ-граммы в левом верхнем углу окна программы и выберите ГРВ-граммы тест-объекта которые необходимо заново обработать.

    6. Нажмите кнопку Обработать и затем Сохранить результаты калибровки и закройте программу GDV Capture 2.

    7. Обновленные калибровочные данные будут автоматически записаны во все ГРВ-граммы съемки, которую Вы видите на экране (и ГРВ-граммы без фильтра и ГРВ-граммы с фильтром, если они есть).
  2. Для произвольного набора ГРВ-грамм:
    1. Убедитесь, что все программы пакета GDV Software закрыты
    2. Запустите любую программу пакета (кроме GDV Capture, GDV Viewer, GDV Scilab)
    3. Перейдите на страницу списка испытуемых. НЕ ЗАГРУЖАЙТЕ sbj-файлы.
    4. Выберите в меню Действие пункт Групповая калибровка…
    5. Запустится GDV Capture 2. Нажмите кнопку Загрузить ГРВ-граммы в левом верхнем углу окна программы и выберите ГРВ-граммы тест-объекта которые необходимо заново обработать.

    6. Нажмите кнопку Обработать.

    7. Затем нажмите Сохранить результаты калибровки, программа GDV Capture 2 закроется.

    8. Откроется окно выбора списка ГРВ-грамм в которые требуется записать обновленные калибровочные данные. Нажимайте кнопку Добавить все файлы из заданной папки - для выбора одного или нескольких файлов из любой папки или нажимайте кнопку Загрузить из папки - для загрузки всех ГРВ-грамм из заданной папки (папка сканируется рекурсивно)
    9. Нажмите кнопку OK - новые калибровочные данные будут записаны во все ГРВ-граммы из составленного списка.
    10. Cохраняем данные с новой калибровкой.

GDV Diagram > Работа с программой > Групповая калибровка


Фильтрация шума

Окно Параметры фильтрации шума открывается кнопкой Шум, расположенной в верхней части страницы загрузки ГРВ-грамм.

ГРВ-грамма представляет собой набор точек (или пикселей), каждая из которых характеризуется интенсивностью свечения - числом в диапазоне от 0 до 255. Нулевое значение интенсивности соответствует отсутствию свечения в данной точке, а значение 255 отвечает максимальной интенсивности свечения.

Спектр ГРВ-граммы - это функция, которая определяет количество точек с заданной интенсивностью в изображении. Типичный спектр ГРВ-граммы представлен на рисунке.

По горизонтальной оси отложена интенсивность, по вертикальной - количество пикселей изображения с заданной интенсивностью. Любая видеокамера, применяемая для регистрации ГРВ-грамм, характеризуется определенной погрешностью работы. В связи с этим, в изображении присутствуют равномерно распределенные по площади ГРВ-граммы «шумовые» точки низкой интенсивности. На рисунке серым цветом обозначена часть спектра соответствующая этим шумовым пикселям. Синим цветом выделена область спектра отвечающая наиболее ярким и значимым точкам газоразрядного свечения вокруг объекта исследования.

Помимо погрешности видеокамеры свой вклад в зашумленность регистрируемой ГРВ-граммы может вносить загрязненность рабочей поверхности прибора. Из-за этого в изображении могут присутствовать отдельные яркие точки или фрагменты, которые также подлежат фильтрации.

В связи с этим, фильтрация шума из ГРВ-грамм происходит в два этапа. На первом этапе осуществляется удаление из изображения пикселей с интенсивностью меньшей либо равной некоторому порогу. Существует два способа задания этого порога:

  1. Порог задается пользователем явно -соответствующий параметр программы называется «абсолютный уровень шума»;

  2. Порог определятся автоматически для каждого изображения по какой-либо характеристике спектра ГРВ-граммы.

Последний способ регулируется двумя параметрами - «относительным уровнем шума» и «базовой интенсивностью». Относительный уровень шума определяет значение порога для фильтрации в процентах от выбранной базовой интенсивности. Имеется возможность выбрать один из пяти типов базовой интенсивности:

  1. Средня - средняя интенсивность, рассчитанная по всем точкам изображения;

  2. Средняя + СКО - средняя интенсивность по всем точкам изображения плюс стандартное отклонение интенсивности;

  3. Медиана - медиана интенсивностей точек изображения;

  4. Пик - значение интенсивности, которое встречается в изображении чаще всего;

  5. Порог - минимальное значение интенсивности, количество точек с которым в ГРВ-грамме составляет менее 1 % от общего количества точек изображения.

На втором этапе фильтрации осуществляется построение списка фрагментов изображения - групп пикселей свечения расположенных рядом (используется принцип восьмисвязности - две точки являются соседними если значения их координат отличаются не более чем на единицу, т.е. соседними к данной точке считаются все, которые находятся в одной из восьми соседних позиций).

Для каждого фрагмента рассчитывается его площадь, т.е. количество точек в нем. Затем происходит удаление из ГРВ-граммы всех фрагментов площадь которых строго меньше заданной. Это регулируется параметром «минимальная площадь фрагмента». Значение этого параметра по умолчанию равно 10 и, обычно, не требует изменения.

Для удобства обработки ГРВ-грамм капель жидкости (которые могут разбрызгиваться в процессе импульсного воздействия), а также в случае наличия засветки по краям изображения, введен еще один парамет - «рабочий радиус». Если этот параметр имеет ненулевое значение, то из изображения удаляются все пиксели, расстояние от которых до центра свечения превышает заданное значение.

Стоит особо отметить, что в процессе фильтрации ни на каком этапе не происходит физического удаления информации из изображений, просто все дальнейшие расчеты в программе происходят так, как если бы отфильтрованные пиксели имели нулевую интенсивность. Поэтому Вы в любой момент можете изменить параметры фильтрации шума без потери данных о шумовых пикселях.

Настройка параметров фильтрации шума возлагается на пользователя. Два основных фактора при выборе этих параметров - это тип используемой ГРВ-камеры и специфические особенности регистрируемых ГРВ-грамм. Рекомендации, помогающие определить корректные значения параметров, приведены в инструкции по эксплуатации к ГРВ-камере. Вы должны руководствоваться принципом выделения наиболее контрастной части свечения, которая, обычно, видна в изображении невооруженным глазом. Также важно, например, при регистрации изображений тест-объекта обеспечить такие параметры фильтрации, чтобы внутренняя область свечения не содержала шумовых пикселей. Для удобства подбора оптимальных параметров фильтрации шума в программе предусмотрено переключение различных типов псевдорасцветки изображений. Можно использовать следующий способ контроля правильности выбора параметров:

  1. Установите «интенсивную» или «энергетическую» палитру для загруженных изображений;

  2. Подберите параметры фильтрации шума так, чтобы обеспечить не очень большое количество желтых точек;

  3. Переключитесь на палитру «исходное изображение»;

  4. Отключите отображение отфильтрованных точек;

  5. Убедитесь, что на экране не пропали видимые невооруженным глазом особенности свечения объекта исследования;

  6. Переключитесь в «монотонную палитру»;

  7. Убедитесь, что ярко-голубые точки не заполняют всю, или почти всю площадь изображения;

  8. При необходимости повторите эту последовательность.

Естественно, процедура подбора параметров осуществляется обычно один раз, с использованием нескольких образцов ГРВ-грамм пальцев и ГРВ-грамм тест-объекта отснятых на конкретном экземпляре ГРВ-камеры.

В программе предлагается несколько параметров фильтрации шума:

  1. Абсолютный уровень шума - удаление всех точек изображения, интенсивность которых меньше либо равна заданному уровню шума. Значение рекомендуется подбирать индивидуально для каждой съемки в пределах от 40 до 90;

  2. Относительный уровень шума (%) - программа осуществляет автоматический выбор абсолютного уровня шума на основании заданного процента от величины базовой интенсивности. Этот алгоритм подбирает уровень шума индивидуально для каждого кадра ГРВ-граммы. Базовая интенсивность рассчитывается на основании анализа гистограммы спектра изображения. В качестве значений этого параметра выбираются статистические характеристики спектра соответствующая: среднему значению спектра плюс величина его квадратичного отклонения, среднему значению спектра, медиане спектра или пику спектра;

  3. Минимальная площадь фрагмента - удаление фрагментов свечения, площадь которых меньше заданной минимальной площади фрагмента. По умолчанию этот параметр равен 30;

  4. Рабочий радиус - удаление всех точек изображения, расстояние от которых до центра свечения больше заданного рабочего радиуса. Центр свечения либо рассчитывается автоматически, как центр тяжести всех точек свечения, либо используется значение явно заданное пользователем при ручной корректировке центра. Для всех кадров видеофильма используется одинаковое значение координат центра свечения;

  5. Коррекция интенсивностей - увеличивается или уменьшается интенсивность всех точек ГРВ-граммы на одинаковую величину, которая автоматически рассчитывается программой так, чтобы характеристики спектра изображения были наиболее приближены к характеристикам спектра ГРВ-грамм тест-объекта отснятых при калибровке.

Применение новых параметров осуществляется кнопкой ОК, при этом загруженные ГРВ-граммы автоматически подвергаются фильтрации шума с новыми значениями параметров и обновляются на экране.

GDV Diagram > Работа с программой > Фильтрация шума


Режимы псевдоокрашивания

ГРВ-граммы в программе можно просмотреть в различных режимах псевдоокрашивания, что позволяет точнее изучить особенность развития газового разряда. Псевдоокрашивание происходит только при отображении ГРВ-грамм в программах комплекса GDV Software, на диске ГРВ-граммы всегда сохраняются в исходной палитре из 256 оттенков серого. Переключить режим псевдоокрашивания можно в верхнем левом углу страницы ГРВ-грамм.

В программе предусмотрены следующие типы псевдоокраски:

  1. Исходное изображение – изображение в том виде, в котором оно получено от видеокамеры и сохранено в файле. Используются серая цветовая гамма, содержащая 256 оттенков серого (от черного до белого);

  2. Инвертированное изображение – используется инвертированная серая цветовая гамма, содержащая 256 оттенков серого (от черного до белого). При использовании этой палитры более четко, чем на исходном изображении видны отдельные мелкие детали свечения и тонкие стримеры;

  3. Интенсивная палитра – точки изображения окрашиваются в один из восьми цветов. Самые яркие точки свечения окрашиваются в оттенки синего, менее яркие точки окрашиваются в оттенки красного, в желтый цвет окрашиваются точки интенсивность которых выше уровня шума, но ниже базового уровня шума для данного кадра. Все точки изображения удаленные алгоритмом фильтрации шума отображаются белым цветом;

  4. Монотонная палитра – все точки изображения удаленные алгоритмом фильтрации шума отображаются черным цветом, остальные точки отображаются однотонным ярким цветом. Используйте эту палитру, при анализе площади свечения по секторам и всего изображения в целом, для того чтобы избежать "обмана зрения", который может возникнуть, если некоторые точки свечения будут плохо видны из-за окраски близкой к окраске "шумовых" точек;

  5. Синяя палитра – используется цветовая гамма, содержащая 256 оттенков синего цвета (от черного к ярко синему). Точки с минимальной интенсивностью свечения отображаются темными (почти черными) оттенками, точки с максимальной интенсивностью свечения отображаются яркими (почти синими) оттенками. Эта палитра отображает свечение в том виде близком к тому, в котором его можно видеть невооруженным взглядом на электроде прибора;

  6. Энергетическая палитра - точки изображения окрашиваются в один из девяти цветов. Самые яркие точки свечения окрашиваются в оттенки голубого, менее яркие точки окрашиваются в оттенки красного, оранжевого и фиолетового цветов. Все точки изображения удаленные алгоритмом фильтрации шума отображаются белым цветом.

GDV Diagram > Работа с программой > Режимы псевдоокрашивания


Корректировка центра и эллипса для ГРВ-граммы пальца

Определение параметров вписанного эллипса и центра свечения происходит автоматически в момент загрузки ГРВ-грамм в программу. В некоторых случаях свечение имеет выбросы и темные участки, которые могут привести к тому, что автоматическое построение контура пальца происходит неточно и требует ручной корректировки.

Для корректировки положения центра пальца надо подвести указатель мыши к отображаемому центру ГРВ-граммы, нажать левую клавишу и перемещать указатель мыши, удерживая левую клавишу нажатой.

Аналогичным образом можно откорректировать ориентацию пальца на ГРВ-грамме. Для этого надо подвести указатель мыши к одной из отображаемых осей ГРВ-граммы, нажать левую клавишу и перемещать указатель мыши, удерживая левую клавишу нажатой. При этом удерживаемая ось будет поворачиваться относительно центра ГРВ-граммы.

Для того чтобы откорректировать эллипс по осям следует выделить соответствующую ГРВ-грамму, навести курсор на ось, по которой будет происходить корректировка, и далее удерживая на клавиатуре клавишу Ctrl передвигать границы контура. Поставив курсор между осями и удерживая клавишу Ctrl, можно выполнить корректировку по двум осям одновременно.

Также на ГРВ-граммы накладывается секторное разбиение соответствующего пальца. Подробную информацию по ГРВ-грамме можно получить при помощи мыши:

  • при перемещении курсора по изображению информация выводится в нижней части окна.

  • при нажатии правой кнопки мыши информация выводится во всплывающем окне.

GDV Diagram > Работа с программой > Корректировка центра и эллипса для ГРВ-граммы пальца


Меню ГРВ-граммы

Для любой ГРВ-граммы, загруженной в программу, можно вызвать контекстное меню. Для этого необходимо нажать правую кнопку мыши на строке, где указан номер кадра и путь к файлу. Появится контекстное меню, состоящее из следующих пунктов:

Пункт меню | Действие
Скопировать в буфер обмена | Копирует кадр, находящийся в данный момент на экране, с учетом расцветки, секторов и обработки в буфер обмена
Вписать в окно | Выводит на экран максимальное количество ГРВ-грамм одновременно (количество изображений на экране зависит от установленного разрешения на мониторе)
Максимальное увеличение | Увеличивает выбранную ГРВ-грамму на все окно
Увеличить | Увеличивает выбранное изображение ГРВ-граммы
Уменьшить | Уменьшает выбранное изображение ГРВ-граммы
Печать всех изображений... | Вызывает окно Предварительного просмотра печати
Печать изображения | Вызывает окно Предварительного просмотра печати и выводит на печать изображение выделенной ГРВ-граммы
Вписать эллипс автоматически... | Программа автоматически строит эллипс для ГРВ-граммы, удаляя изменения ручной корректировки
Перевернуть изображение на 180°... | Изображение будет программно повернуто на 180˚
Зеркально отобразить изображение по горизонтали... | Изображение - это прямоугольная матрица точек вида I [ x , y ] размерами w на h. "Зеркально отобразить изображение по горизонтали..." - значит преобразовать изображение таким образом что I [ x , y ] переходит в позицию I [ w-x , y ]
Сохранить расцвеченные изображения... | Программа сохранит ГРВ-граммы в том виде, в котором они в данный момент отображены на экране (с использованием одной из стандартных расцветок - энергетическая палитра, интенсивная палитра, инвертированное изображение и т.п.)
Рассчитать усредненное изображение... | Программа рассчитает и предложит сохранить усредненное изображение по всем снятым ГРВ граммам.
Показать | Вызывает окно просмотра ГРВ-граммы

GDV Diagram > Работа с программой > Меню ГРВ-граммы


Построение и просмотр диаграммы

После загрузки ГРВ-грамм следует выполнить построение ГРВ-диаграммы при помощи кнопки Рассчитать, расположенной внизу справа на странице ГРВ-граммы. По завершении процесса обработки появится страница Диаграмма с графиками диаграммы, отражающими распределение комплексного ГРВ параметра по органам и системам в сопоставлении с состоянием практически здорового человека, сформированными на основании базы данных. Норме соответствует среднее кольцо зеленого цвета. Превышение нормы проекцируется на внешнее кольцо, снижение - на внутреннее. Диаграммы делятся на сектора, связанные с определенной частью организма человека. При перемещении мыши по области графика программа выводит подсказку о текущем секторе. Кривые на диаграммах обозначаются разным цветом, и каждому цвету соответствует определенные ГРВ-граммы испытуемого.

Под графиком с левой стороны расположена легенда, показывающая по каким данным построены кривые на графике диаграмм. Если в программу загружено несколько испытуемых, то можно выбрать текущую кривую на легенде. Для текущей, выделенной кривой на графике отображаются числовые параметры по секторам. Двойным щелчком левой клавиши мыши над строкой легенды можно включать или выключать отображение данных. При этом галочка, расположенная слева от строки, изменяется на крестик.

С правой стороны находятся переключатели, позволяющие при помощи установки и удаления галочки показать/скрыть данные с фильтром или без него и включить/выключить режим выделения по одному, а также кнопки изменения масштаба диаграммы. При установке включении режима выделения по одному на графиках будет отражаться данные только по одному испытуемому, выбрать которого можно из легенды, расположенной с левой стороны.

На странице Диаграмма имеется возможность просмотра изображения ГРВ-граммы для выделенного сектора. Для этого необходимо двойным щелчком левой кнопки мыши нажать на график. Появится окно с изображением ГРВ-граммы, на которой будет отмечен выделенный Вами сектор, а также основные данные по ГРВ-грамме. Если на графике отображено несколько испытуемых, то изображения ГРВ-граммы будет выводиться для выделенного испытуемого, на графике он обозначается более жирной линией.

С помощью кнопки Печать... можно распечатать изображение полученной диаграммы.

Кнопка Перейти к списку испытуемых позволяет вернуться к странице Список испытуемых.

GDV Diagram > Работа с программой > Построение и просмотр диаграммы


Просмотр графиков интегральных параметров

Дополнительные параметры выводятся в виде гистограмм на странице Интегральные параметры.

В верхней части страницы имеется возможность выбрать испытуемого, а также сравнить интегральные параметры всех испытуемых.

С правой стороны страницы можно выбрать интегральный параметр (Интегральная площадь, Интегральная энтропия, Коэффициент активации), по которому требуется сравнить данные испытуемых.

Интегральная Площадь

Интегральная площадь характеризуется следующими уровнями:

  • Норма (отражается зоной зелёного цвета) - интервал оптимальной зоны количественных колебаний процессов на уровне функционального стимулирования, отражает наличие нормальных структурных и функциональных предпосылок для нормальной жизнедеятельности организма и психики.

  • Ниже Нормы (зона красного цвета) - замедление биохимических и информационных процессов в системах организма и органах человека, нарушающих оптимальный режим функциональной деятельности организма. Ослабление процессов жизнедеятельности организма и психики. Может привести к дисфункции или патологии определенных систем и органов человека.

  • Выше Нормы (зона желтого цвета) - ускорение биохимических и информационных процессов в системах организма и органах человека. Переводит организм на экстремальный режим функционирования, что может привести к перегрузке и дисфункции систем и органов человека.

Интегральная Энтропия

Интегральная энтропия отражает состояние функционирования клетки, органа и всего организма человека. Общий диапазон значений делится на три уровня: Нормальная энтропия (значение Интегральной энтропии находится в области зеленого цвета), Повышение энтропии (значение находится в области желтого цвета) и Понижение энтропии (значение находится в области красного цвета).

Нормальная энтропия

Характеризует активное протекание всех реакций и процессов жизнедеятельности, поддерживающих адаптивную способность и гомеостаз на оптимальном уровне.

Повышение энтропии свидетельствует о возникновение новых процессов, ведущих к увеличению активности клетки или органа, то есть присоединение к системе чужеродных компонентов, вступающих в реакцию с имеющимися нормальными компонентами, тем самым вызывающими значительное увеличение промежуточных и конечных продуктов. Накопление новых продуктов обмена приводит к нарушению нормального функционирования клетки, ткани, органа и всего организма, за счет патологической активности многих из них. Возможны возникновение ацидоза – закисления, или алкалоза – ощелачивания среды, что, в свою очередь может привести к изменению активности нормальных компонентов среды.

При достижении высоких значений, физиологические процессы носят компенсаторный характер, и направлены на сохранение функции и защиту клетки, органа или организма, но они приводят также к истощению за счет не рационального использования резервов, и, как следствие, к различным компенсаторным нарушениям. В таких случаях энтропия не возвращается к своему нормальному значению, а остается на несколько повышенном уровне, т.к. при таких компенсаторных изменениях структуры изменяются и условия для протекания процессов жизнедеятельности.

Понижение энтропии – это свидетельство замедления всех окислительно-восстановительных реакций, реакций катаболизма и анаболизма, то есть выключение из системы многих ее компонентов, прекращение различных реакций, исчезновение поля для развертывания этих реакций. Это состояние может встречаться при патологии, например, при атрофических изменениях, но может наблюдаться и в норме (во сне). Понижение энтропии может наблюдаться на фоне, например, истощения, когда нет продуктов превращения и все резервы израсходованы.

Коэффициент активации

Коэффициент активации отражает уровень психического состояния человека.

Границы нормы располагаются в пределах зеленого поля, т.е. от 2 до 4 единиц (цифры представляют собой условное деление уровня психического состояния). Если параметр «Коэффициент активации» находится в пределах нормы, то это свидетельствует о нормальном психо-эмоциональном состоянии исследуемого на данный момент времени. Под нормальным психо-эмоциональным состоянием в данном случае понимается такое состояние человека, которое для него характерно в повседневной жизни, если оно не патологическое. Например, если человек всегда находится в слегка возбужденном состоянии, то оно для него и является нормальным, в то же время если человек болен и для него характерна апатия и гипобулия (снижение воли), то это состояние не является нормальным, т.к. связано с патологией.

Если Коэффициент активации располагается в интервале от 4 до 6, то это соответствует кратковременному изменению психо-эмоционального состояния человека, вызванное внешними воздействиями, т.е. экзогенное изменение. Например, это может говорить о том, что исследуемый человек испытал кратковременное перенапряжение на работе, в семье, в общественном транспорте и т.д. незадолго до проведения исследования. Возможно, человек находится в стрессе на стадии тревоги. В таком случае человеку следует предложить посидеть пятнадцать – двадцать минут, «успокоится». Однако в этой зоне индекс активации может располагаться и в норме, что характерно, например, для энергичных или для физически крепких людей. Такой Коэффициент активации может быть и у лиц, находящихся в тревожном ожидании, например у спортсменов перед соревнованием или у студентов перед экзаменом. В большинстве случаях, когда Коэффициент активации попадает в зону от 4 до 6 единиц, можно говорить, что это физиологичное, чаще кратковременное, повышение уровня психической активности.

При расположении Коэффициент активации в зоне от 6 до 8 стоит предположить развившееся экзогенное психическое отклонение, такое, например, как неврастения или другой невроз, а также психоз. В этом случае человеку можно посоветовать сменить режим работы, больше спать, принимать поливитамины. Кроме того, следует направить человека на консультацию к специалисту. Однако стоит принять во внимание, что даже такое повышение уровня активации не обязательно следствие патологических изменений, и может быть связано с повышенной эмоциональностью лиц, и вызвано реакцией таких людей на различные жизненные ситуации.

Самая крайняя степень повышения Коэффициент активации от 8 до 10. Такое распределение соответствует стрессу в стадии сопротивления. Причем если действие стрессора прекратится на этом этапе, до наступления истощения, то организм восстановится без вреда для здоровья. Однако такой высокий уровень индекса активации может встречаться и при патологическом стрессе – дистрессе.

Если же Коэффициент активации понижен и находится в области от 0 до 2, то можно думать о депрессивном синдроме, о стрессе в фазе истощения, а так же о медикаментозном снижении уровня психической активности, например под действием транквилизаторов, седативных, наркотических и др. препаратов. Кроме того, такое распределение возникает во время глубокой фазы сна. Так же такой уровень индекса активации может быть и в норме, что встречается у энергетически или физически слабых людей.

Если значение параметра выходит из зоны нормы, то рядом с гистограммой появляется предупреждающий символ - мерцающий восклицательный знак.

При помощи кнопки Печать... можно вывести на печать полученные данные.

Кнопка Перейти к списку испытуемых возвращает на страницу Список испытуемых.

GDV Diagram > Работа с программой > Просмотр графиков интегральных параметров


Таблица данных

Страница Таблица данных является последней страницей программы и содержит все числовые данные ГРВ-диаграммы. Если в программу загружено несколько съемок, то над таблицей можно выбрать испытуемого и съемку, для которых выводится таблица. Также можно выбрать вид ГРВ-грамм, для которых строится таблица параметров (без фильтра или с фильтром).

Таблица содержит шесть колонок. В первой из них отражаются части организма человека, связанные с определённым сектором, во второй колонке предоставляются данные о пальце и секторе, которые отвечают за эти части организма. Третья и четвертая колонки содержат информацию о конкретных значениях вектора ГРВ-диаграммы для органа, или системы организма человека по левой и правой стороне соответственно, пятая - среднее значение между правой и левой сторонами, а шестая отражает данные значении разности между ними. Числовые данные, которые соответствуют норме выделяются зеленым цветом, ниже нормы - красным, и выше неё - желтым. Это сделано для удобства просмотра таблицы и возможности определять на какие органы и системы организма стоит обратить внимание.

Таблицу данных можно сохранить в текстовый файл или распечатать.

Кнопка Сохранить... позволит сохранить рассчитанные данные.

Имеется возможность вернуться к странице Список испытуемых при помощи кнопки Перейти к списку испытуемых.

GDV Diagram > Работа с программой > Таблица данных


Печать ГРВ-грамм

Программа позволяет вывести на печать загруженные ГРВ-граммы с наложенными секторными разбиениями. Для этого необходимо нажать кнопку Печать ГРВ-грамм на странице ГРВ-граммы.

Перед печатью программа откроет окно предварительного просмотра, откуда можно будет распечатать или сохранить изображение.

Описание работы с окном Предварительный просмотр печати приведено в разделе Печать графиков и таблиц.

GDV Diagram > Работа с программой > Печать ГРВ-грамм


Печать графиков и таблиц

Программа позволяет распечатать графики ГРВ-диаграммы, интегральных параметров и таблицу данных. На этих страницах имеется кнопка Печать..., которая открывает окно Предварительный просмотр печати.

В верхней строке этого окна имеется несколько кнопок:

  • Закрыть – закрывает окно предварительного просмотра

  • Печать... – переход к окну «Настройки печати» с последующей печатью

  • << >> – позволяет просмотреть предыдущую и следующую страницу

  • |<< >>| – позволяет просмотреть первую и последнюю страницу

  • Сохранить в файл – открывает окно сохранения файла изображения печатаемой страницы в форматах Windows Bitmap (расширение BMP) или Windows Enhanced Metafile (расширение EMF)

  • 60% – масштаб предварительного просмотра графика

В нижней строке окна расположена информация о количестве страниц.

При нажатии кнопки Печать откроется окно Настройка печати. Если подключен цветной принтер, то программа автоматически настраивает принтер на цветную печать. По умолчанию ориентация печати установлена Альбомная.

Для сохранения графиков рекомендуется использовать формат EMF, т.к. во-первых, изображения в этом формате занимают гораздо меньше места на диске, чем аналогичный BMP файл, а во-вторых, при масштабировании таких изображений в документах (например, в редакторе Microsoft Word) искажения будут минимальны.

GDV Diagram > Работа с программой > Печать графиков и таблиц


Сохранение печатаемых документов

Любой документ (график или ГРВ-граммы), который формируется в программе, можно сохранить из окна Предварительный просмотр печати. Для этого следует нажать в этом окне кнопку Сохранить в файл, расположенную в верхней части.

Тип файла по умолчанию установлен Windows Enhanced Metafile (расширение EMF), но также можно выбрать тип Windows Bitmap (расширение BMP).

Рекомендуется для сохранения графиков использовать формат EMF, т.к. во-первых, изображения в этом формате занимают гораздо меньше места на диске, чем аналогичный BMP файл, а во-вторых, при масштабировании таких изображений в документах (например, в редакторе Microsoft Word) искажения будут минимальны.

GDV Diagram > Работа с программой > Сохранение печатаемых документов